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Prerequisite knowledge
Prior experience working with Flash
Professional CS5 is not required. This
introductory article provides all the
steps you need to get started. Although
this sample project includes some
ActionScript code, previous knowledge
of programming is not necessary.
 
Note: If desired, you can download the
sample files to review a working version
of the completed project. Otherwise, just
follow along with the instructions
provided below to create the sample
project from scratch.

User level
Beginning

Required products

Flash Professional (Download trial)

Sample files

SimpleFlash.zip (423 KB)

Adobe Flash Professional CS5 is an authoring tool that you can use to create presentations, applications, and other
content that responds to user interaction. Flash projects can include simple animations, video content, complex
user interfaces, applications, and everything in between. In general, individual projects created with Flash
Professional are called applications (or SWF applications), even though they might only contain basic animation. You
can make media-rich applications by including pictures, sound, video, and special effects.

The SWF format is extremely well suited for delivery over the web because SWF files are very small and take little
time to download. Flash projects often include extensive use of vector graphics. Vector graphics require significantly
less memory and storage space than bitmap graphics because they are represented by mathematical formulas
instead of large data sets. Using bitmap graphics in Flash projects results in larger file sizes because each individual
pixel in the image requires a separate piece of data to represent it. Additionally, Flash allows you to select graphic
elements and convert them to symbols—making them easier to reuse and further improving performance when
SWF files are viewed online.

Creating a FLA file and adding graphic elements

To build an application in Flash Professional CS5, you create vector graphics and design elements with the drawing
tools and import additional media elements such as audio, video, and images into your document. Next, you use
the Timeline and the Stage to position the elements and define how and when they appear. Using Adobe
ActionScript (a scripting language) you create functions to specify how the objects in the application behave.

When you author content in Flash Professional (by choosing File > New), you work with the master document,
which is called a FLA file. FLA files use the file extension .fla (FLA). While editing a FLA file in the Flash authoring
environment, you'll notice that the user interface is divided into five main parts:

The Stage is like the canvas that defines the visible area during playback; you arrange  graphics, videos,
buttons, and other elements on the Stage while authoring projects.

The Timeline controls the timing that specifies when elements in the movie appear on the Stage. The playhead
begins at Frame 1 and moves from left to right as the movie proceeds through the frames. Drag the layers in
the Timeline to arrange the layering order of graphics on the Stage. Graphics in the higher layers appear to be
placed on top of the graphics in the lower layers.

The Tools panel contains the tools used to select objects on the Stage, create text elements, and draw vector
graphics.

The Property inspector displays contextual information about the attributes of any selected object; you can
edit these options to adjust an object's settings.

The Library panel contains media elements and symbols that are stored for a project. Use this panel to manage
and organize the project's elements. When you publish a SWF file, only the Library items you actually use are
included in the published file; you don't have to "clean out" unused elements that weren't used because they
won't increase the published SWF file's size (although they do increase the size of the master FLA file).

The five areas of the workspace are identified in Figure 1.
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Figure 1. Flash Professional CS5 user interface is comprised of five main parts. (Click to enlarge.)

ActionScript code allows you to add interactivity to the elements in your document. For example, you can add code
that causes a button to display a new image when it is clicked. You can also use ActionScript to add logic to your
applications. Logic enables your application to behave in different ways depending on the user's actions or other
conditions. There are different versions of ActionScript. Flash Professional uses ActionScript 3 when an ActionScript
3 or Adobe AIR file is created, or ActionScript 1 and 2 when an ActionScript 2 file is created in the New Document
dialog box.

Flash includes many features that make it powerful but easy to use, such as prebuilt drag-and-drop user interface
components, built-in motion effects that you can use to animate elements on the Timeline, pre-written code
snippets, and special effects that you can add to media objects.

When you have finished authoring your FLA file, you publish it by selecting File > Publish (or pressing Shift+F12).
The publish operation generates a compressed version of your file with the extension .swf (known as a SWF file).
Adobe Flash Player is used to play the SWF file in a web browser or as a stand-alone application. Although you don't
upload or distribute the FLA file itself, you'll always want to keep a copy of the master document. If you need to
make any changes, you can open the FLA file in Flash, edit it, and then publish an updated SWF file.

Creating a simple FLA file

This tutorial guides you through the process of creating a basic FLA document. You'll use this workflow when
authoring projects in Flash Professional. The first step involves creating a new document:

1. Choose File > New.

2. In the New Document dialog box, the ActionScript 3.0 file type is selected by default (see Figure 2). If
ActionScript 3.0 is not selected, select it now. Click OK.

Figure 2. The New Document dialog box displays the file types you can create in Flash Professional.

3. Use the workspace drop-down menu located on the upper right of the screen to select the Essentials
workspace layout option (see Figure 3). This step ensures that the layout of the panels in Flash Professional
match the arrangement of the panels displayed in the screen shots for this tutorial.

Note: Later, you can create a preset of your own custom workspace by positioning the panels in any way that you
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prefer. Choose the New Workspace option and enter a name to save your personal configuration. Once it's saved,
you can reset the workspace by choosing its name from the workspace menu.

Figure 3. Select the Essentials option to see the workspace layout used for this tutorial.

4. Click the Properties tab in the upper right side of the user interface to view the Property inspector, which
displays the Stage properties for the file when no other objects are selected.

5. By default, the Property inspector is vertically aligned along the right side of the workspace. The Size section
displays the current Stage size setting as 550 ! 400 pixels (see Figure 4). The Stage background color swatch is
set to white. You can change the color of the Stage by clicking the swatch and selecting a different color in the
color picker that appears.

Figure 4. The Property inspector displays the Stage size and the background color.

Tip: You can set the background color of the Stage in the Flash movie by choosing Modify > Document or by
selecting the Stage and then modifying the Stage color swatch in the Property inspector. There's no need to draw a
rectangle to define the background color. When you publish your movie, Flash sets the background color of the
published HTML page to the same color as the Stage background color (if you choose to generate an HTML file).

6. Choose File > Save.

7. Select the location to save the FLA file on your hard disk. Name it SimpleFlash.fla and then click Save. Make a
note of the location where you save the FLA file because you'll need to find this directory at the end of this
tutorial.

Drawing a circle on the Stage

After you've created your Flash document, you are ready to add some artwork to the project. Drawing shapes is a
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After you've created your Flash document, you are ready to add some artwork to the project. Drawing shapes is a
common task in Flash. When you use the drawing tools in the Tools panel, the vector graphics you create can be
edited at any time. The following steps describe how to create a circle; later, you'll use this circle to create some
basic animation. Follow these steps:

1. Select the Oval tool from the Tools panel (see Figure 5).

Figure 5. Tools with a triangle in the bottom left corner contain more than one option; click and hold the shape tool icon to select
the Oval tool from the list that appears in the Tools panel.

2. Use the stroke color swatch in the Property inspector to select the No Color option (red diagonal stripe) from
the Stroke Color Picker (see Figure 6).

Figure 6. The universal "no" symbol (red diagonal stripe) indicates that the color swatch is set to the No Color option in the Stroke
color picker.

3. Select a color of your choice from the Fill color picker, located directly below the Stroke color picker. Choose a fill
color that contrasts well with the Stage color. In this example, an oval with a blue fill color is displayed on top of
a red Stage color.

4. Whenever you draw a vector shape, you have the option of selecting two drawing modes: Merge drawing
mode and Object drawing mode. For the purposes of this tutorial, click the drawing mode button to select the
Object drawing mode at the very bottom of the Tools panel. When the Object drawing mode is selected, the
button will appear darker and selected, as shown in Figure 7.
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Figure 7. The Drawing mode button is a toggle that alternates between modes; choose Object drawing mode by clicking the button
to make its background appear darker.

To learn more about the two drawing mode options, see the Drawing modes section of the Flash Professional
online documentation.

5. While the Oval tool still selected, press and hold the Shift key. Draw a circle on the Stage by Shift-dragging on
the Stage (see Figure 8). The Shift key is a modifier key; when you press and hold the Shift key while drawing or
transforming a shape with the Oval tool, Flash constrains the Oval tool shape to a circle that is perfectly
symmetrical.

Note: The Shift key works similarly with other auto shapes; when you press and hold Shift while drawing a shape
with the Rectangle tool, you'll create a perfect square.

Figure 8. Press and hold the Shift key while using the Oval tool to draw a circle on the Stage.

Tip: If you're drawing your circle and you see only an outline of the shape instead of a fill color, first check to ensure
that the stroke and fill options are set correctly in the Property inspector while the circle is selected. If the fill color
swatch is set to a color and the stroke is set to No Color, the settings are correct. Next, make sure that the option to
Show Outlines is not selected in the layers area of the Timeline. (There are three icons to the right of the layer
names: eyeball icon, lock icon, and outlines icon. Double-check that the outlines icon displays a solid fill and not just
a square outline. If you are not sure if the Show Outlines option is enabled, click the icon repeatedly to toggle the
visual state between normal view and outline view.)

Creating a symbol and adding animation

After drawing some artwork, you can turn it into a reusable asset by converting it to a symbol. A symbol is a media
asset that can be reused anywhere in your document without the need to re-create it. Symbols can contain bitmap
and vector images and animations, along with other types of content.

It is common to use symbols to create tweened animations. You can also use symbols to store graphic content (as
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described in the next set of steps). As you become more familiar with Flash Professional, you'll use symbols to
structure applications and interactivity using multiple timelines. Symbols are useful for compartmentalizing parts of
a project to make it easier for you to edit specific sections later. Follow these steps to create a symbol:

1. Click the Selection tool in the Tools panel (see Figure 9).

Figure 9. The Selection tool is the first item displayed in the Tools panel.

2. Click the circle on the Stage to select it. A bounding box selection appears around the circle.

3. While the circle is still selected, choose Modify > Convert to Symbol (or press F8) to access the Convert to
Symbol dialog box (see Figure 10). Enter the name of the symbol in the Name field. Use the Type menu to select
the Movie Clip option.

Tip: You can also convert a graphic into a symbol by selecting it and dragging it into the Library panel.

Figure 10. Enter a descriptive name for the symbol in the Convert to Symbol dialog box.

4. Click OK. A square bounding box is displayed around the circle symbol. You've just created a reusable asset,
called a symbol, in your document. In this case, you created a movie clip symbol named my_circle. (For more
information about symbols, read Working with symbols in the Flash Professional online documentation.)

If the Library panel is not open, choose Window > Library to access it. The new symbol is now listed in the Library
panel. (When you drag a copy of the symbol from the Library panel to the Stage, the copy on the Stage is called an
instance of the symbol.)

Animating the circle

In this section, you'll use the symbol in your document to create a basic animation that moves across the Stage:

1. Select the circle on the Stage and drag it off the Stage area to the left (see Figure 11).

Figure 11. Reposition the instance of the my_circle symbol to the left of the Stage area.

2. Right-click the circle instance on the Stage and choose the option to Create Motion Tween in the menu that
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appears. Notice that the Timeline is automatically extended to Frame 24 and the red marker (the current frame
indicator, also known as the playhead) moves to Frame 24 (see Figure 12). This indicates that the Timeline is
prepared for you to edit the ending location of the symbol and create a one-second animation—assuming that
you haven't changed default frame rate for the project from 24 fps in the Property inspector. A span of 24
frames is the equivalent of one second at a rate of 24 fps. (For more information about the Timeline, read
Working with timelines in the Flash Professional online documentation.)

Figure 12. The Create Motion Tween operation automatically extends the frames in the Timeline and places the playhead on Frame
24.

3. While the playhead is still on Frame 24 of the Timeline, select the circle instance on the Stage and drag it to the
right, just past the Stage area. This step of relocating the instance creates a tweened animation. On Frame 24,
notice the diamond-shaped dot (known as a property keyframe) that appears. On the Stage, also notice the
motion guide that indicates the circle's path of motion between Frame 1 and Frame 24 (see Figure 13).

Figure 13. After creating a 24-frame tween animation, the circle is located at the far right at the end of the animation (when the
playhead is located on Frame 24 of the Timeline).

4. In the Timeline, drag the red playhead back and forth from Frame 1 to Frame 24 to preview the animation; this
is known as scrubbing the Timeline.

5. You can change the circle's direction in the middle of the animation. First, drag the playhead to Frame 10 in the
Timeline. Then select the circle and move it to another location, further down on the Stage. Notice that the
change is reflected in the motion guide and the new dot (property keyframe) appears on Frame 10 of the
Timeline (see Figure 14). The property keyframes on the Timeline mark the timing of the animation, indicating
the frames whenever objects change on the screen and storing the properties of the object that change. In this
example, it is the circle's location on the Stage (known as its X and Y or horizontal and vertical) properties that
are changing as the playhead moves across the Timeline.
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Figure 14. After placing the playhead on Frame 10 and dragging the circle instance down on the Stage, the motion guide of the
tweened animation and the property keyframe in the Timeline reflect the location change of the animated circle.

6. Experiment with editing the animation by changing the shape of the motion guide path. Click the Selection tool
in the Tools panel and then click a section of the motion guide line. Drag it to bend the line shape (see Figure
15). When you bend the motion path, you cause the animation to follow along a smooth curved line instead of
a rigid straight line.

Figure 15. Use the Selection tool to adjust the tweened animation's motion path; rather than a straight line the edited motion guide
line is now curved.

7. Choose Control > Test Movie to test the FLA file and watch the animation play back in Flash Player.

8. The movie loops automatically, so you can watch the circle move across the window repeatedly. When you are
finished, close the Test Movie window.

Using a stop action to stop the Timeline from looping

When you tested the movie, the animation loops by default as the movie plays in Flash Player. This occurs
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When you tested the movie, the animation loops by default as the movie plays in Flash Player. This occurs
automatically because in Flash Professional, the Timeline is set up to loop back to Frame 1 after exiting the last
frame—unless you instruct the movie to do otherwise. When you want to add a command that controls the
Timeline, you'll add ActionScript code to a keyframe (indicated by a dot symbol) on the Timeline. This is known as
adding a frame script.

Tip: Keyframes are used to place ActionScript and assets on specific frames in the Timeline. When you review the
Timeline of a FLA file, you can locate scripts and content by looking for the keyframe dots. Keyframes that have
frame scripts display a lower case "a" symbol.

Follow the steps below to add ActionScript code to your FLA file. You'll add one of the most common Timeline
commands, which is called the stop action:

1. It's always a good idea to name your layers if you have more than one. A large project can quickly become
unmanageable if its layers are not descriptively named. Double-click the name to rename Layer 1. In the field
that appears, enter the new name: animation.

2. Click the New Layer button (page icon) in the lower left of the Timeline panel. In an ActionScript 3 file, the
ActionScript code must be added to the Timeline. It's considered best practice to create a layer named actions
at the top of the layer stack, dedicated to holding the ActionScript code. Rename the new layer you just created
to: actions. Make sure it is located above the animation layer. Now that you've created a layer to place your
scripts, you can add keyframes to the actions layer to associate the ActionScript code with specific frames.

3. Move the playhead to Frame 24. Click the actions layer at Frame 24 (to highlight the last frame on the actions
layer). Insert a keyframe on Frame 24 of the actions layer by choosing Insert > Timeline > Keyframe (or pressing
F6). Notice that an empty, blank keyframe appears (you can tell that the new keyframe doesn't contain any
graphics because the dot icon for the keyframe is hollow, rather than displaying a solid color).

4. Select the new keyframe with the Selection tool. Open the Actions panel (Window > Actions). The Actions panel
contains the Script window, which is a large text field you'll use to type or paste ActionScript code directly into
your FLA file. Place your cursor in the text area next to the number 1 (line 1) and type in the following action:

stop();

Note: This step assumes that you're using the default mode of the Actions panel. If the Actions panel is in Script
Assist mode, it won't allow you to type directly into to the text area. To return to the default mode, uncheck the
magic wand icon in the upper right corner of the Actions panel.

5. After typing the line of ActionScript code in the Script window, you'll notice that a little "a" icon appears above
the keyframe in the actions layer of the Timeline. This indicates that the keyframe contains a frame script (also
known as an action). At this point, your Timeline should look similar to Figure 16. Close the Actions panel. If you
need to edit the code, you can always select the keyframe in the Timeline and then open the Actions panel
again.

6. Choose Control > Test Movie to test the FLA file and watch it play in Flash Player. Notice that this time, the
animation doesn't loop. You can return to Flash and test the movie again to watch the movie play again.

Figure 16. Add the stop action frame script to Frame 24 of the actions layer.

7. When you are finished previewing the animation, close the Test Movie window.

8. Back in Flash, save the FLA file.

Publishing SWF files

When you are finished creating your FLA file, and you've tested it repeatedly, you are ready to publish it. The files
that you output when publishing can be uploaded to a host server so that the project can be viewed in a browser.
When you publish the file, Flash Professional compresses the data in the FLA file and generates a much smaller,
more compact (and non-editable) SWF file. It's important to note that the FLA is your master, authoring file. Always
keep the FLA file handy in case you need to make changes to the project. The SWF file that is generated by Flash
when you publish a project is the file that you'll embed in a web page. If you are familiar with Adobe Photoshop, you
can think of the FLA file as the equivalent of a master PSD file, and the SWF file as the equivalent of the exported
JPEG file that will be inserted on a web page.
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While you can choose to edit the publish settings and only publish the SWF file (and then use Adobe Dreamweaver
or another HTML editor to insert the SWF file in a page) the Publish command makes things even easier. You can set
the publish settings to automatically generate an HTML file that contains the code to embed the SWF file for you.

Follow these steps to publish the FLA file and output the SWF file with the HTML file, so that you can view the
published project in a browser:

1. Choose File > Publish Settings.

2. In the Publish Settings dialog box, select the Formats tab. Verify that only the Flash and HTML options are
selected (see Figure 17). This selection causes Flash to publish only the SWF file and an HTML file with the embed
code. The HTML file is used to display the SWF file in a web browser. (The web browser then calls Flash Player, an
installed plug-in, to render the contents of the SWF file onscreen).

Figure 17. Select the Flash and HTML options in the Formats tab of the Publish Settings dialog box.

3. In the Publish Settings dialog box, select the HTML tab and verify that Flash Only is selected in the Template
pop-up menu (see Figure 18). This template creates a simple HTML file that contains only your SWF file when
previewed in a browser.
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Figure 18. Select Flash Only from the Template menu in the HTML tab of the Publish Settings dialog box.

4. Click OK.

5. Choose File > Publish to export the web-ready SWF and HTML files from Flash.

6. Open your web browser. Choose File > Open. Navigate to the folder where you saved your FLA file. The
SimpleFlash.swf and SimpleFlash.html files have been saved there. (By default, Flash always saves the published
files in the same folder alongside the FLA master file.) Select the file named SimpleFlash.html.

7. Click Open. The SWF file embedded in the HTML page now appears in the browser window (see Figure 19).

Figure 19. The file SimpleFlash.swf is an example of a basic Flash animation, which appears in the browser after publishing the file.
(Click the button to replay the movie.)

You've successfully completed your first FLA file. To learn more about publishing your document, read the
Publishing and Exporting section in the Flash Professional online documentation.
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Adding a replay button to restart the animation

In an earlier section, you stopped the animation from looping by adding a stop() action to the last frame of the

Timeline. When the playhead reaches the last frame, it is instructed to stop, which prevents it from looping back to
Frame 1.

In this set of instructions, you'll learn how to add a Replay button. When a user clicks the button, it causes the
playhead to begin playing from Frame 1 again. This is the behavior of the example shown in Figure 19.

Flash is extremely flexible. There are many strategies that you could use to create a Replay button, including
restarting the playhead when a user presses a key on their keyboard, or when they click on the Stage, or when they
click a button. To achieve any of these options, you'll add some ActionScript code that responds to the user
interactivity at runtime (while the SWF file is playing). This section is a little more advanced than the previous
sections—it covers some new concepts that you'll use to control the behavior of your Flash movies with
programming.

Follow these steps to add a Replay button and the corresponding ActionScript to your file:

1. In Flash, it is a best practice to create a new layer for each element in the project (with the exception of
ActionScript code, which can be placed on any frame on the top-level actions layer). Click the New Layer button
(page icon) in the Timeline to create a new layer for the button graphic. Double-click the default layer name and
rename it: Button.

2. Open the Components panel (Window > Components) and drag a button component from the UI Components
folder to the Stage. Position the button in the lower middle of the Stage area, or any desired location.

3. While the Button component still selected, open the Property inspector and locate the text field at the top
named <Instance Name>. Enter the name for the button instance:  replay_btn. This is an important step. By
naming the button instance, you'll be able to reference it by name using the ActionScript you'll add to the
project. If the button instance's name does not exactly match the button's name specified in the code, the
behavior won't function as expected.

Note: One of the most common mistakes is to enter the name of a frame label, rather than entering the
instance name of an object on the Stage. Be very careful to always select the object on the Stage first. Then you
can access the Property inspector to check that the panel refers to the selected symbol and indicates that an
instance is selected. Verify that the field says "<Instance Name>" before you type the name of the instance. If
the Property inspector refers to a frame, it means you've accidentally clicked the Timeline. Naming instances can
be confusing until you are familiar with the options presented for selected symbol instances and selected
keyframes. One thing to check: If you accidentally enter a name in the Property inspector while a keyframe is
selected (instead of an object on the Stage), you'll see a red flag icon appear in the Timeline on the keyframe.
Frame labels can be very helpful when creating navigation that jumps to different frames in the Timeline; for
this example, however, it is critical that you select the button on the Stage and enter the instance name of the
button in the button layer as replay_btn. Also make sure there are no typos; otherwise the script will not work.

4. To update the text label of the button that is displayed on the Stage, enter the text Replay into the label field in
the Component Parameters area in the Properties panel. This label helps users understand what the button will
do. It is purely visual and does not affect the performance of the code. If you'd prefer that the button display a
different label, you could enter Rewind, Again, or a different label of your choosing.

5. Select the keyframe on Frame 1 of the actions layer. Open the Actions panel (Window > Actions). Copy the code
snippet below and paste it into the Script window:

import flash.events.MouseEvent;
  
function onClick(event:MouseEvent):void
{
   gotoAndPlay(1);
}
replay_btn.addEventListener(MouseEvent.CLICK, onClick);

6. Take a few moments to read through the code. Notice that the second line begins by declaring a function
named onClick. The last line of code uses theaddEventListener method, which registers the function as

an "event listener" for the button's "click" event. The translation of this code essentially says: "When a user clicks
the button named replay_btn, run the function named onClick. When the onClick function runs, it

instructs the playhead to jump to Frame 1 of the Timeline and begin playing the frames."

This is the standard format used when writing ActionScript 3; one section checks for user interactivity (such as a
mouse click) and that triggers another function to respond to timing cues from objects in Flash Player. In this
case, the event handler function instructs Flash Player to return to Frame 1 and start playing the Timeline again.
(You'll use a similar syntax of creating an event handler function and assigning it to a button instance any time
you create an interactive button in Flash.)

Tip: You can use the Code Snippets panel as a shortcut when adding events to buttons.



11-12-13 3:04 PMCreating your first Flash Professional CS5 document | Adobe Developer Connection

Page 13 of 21http://www.adobe.com/devnet/flash/articles/flash_cs5_createfla.html

Comments (62)

Neil Heke

May 8, 2010

Arteby

May 12, 2010

mohammedali80

June 17, 2010

Thien Phan

July 2, 2010

mominaustintx

July 8, 2010

ukujfm

August 1, 2010

robert brady

August 6, 2010

thelctrclengnr

August 15, 2010

konfoozled

August 25, 2010

7. Choose Control > Test Movie to test the FLA file. The animation plays once and then stops. Click the Replay
button to restart the animation and watch the circle move across the Stage again.

8. Close the Test Movie window and save your FLA file.

Where to go from here

There are many online resources you can use to learn more about working with Flash Professional:

The Getting Started section in the Flash Developer Center outlines where to go next, depending on your
interests and goals.

The Learn Flash Professional show on Adobe TV provides an entire set of video tutorials that illustrate what you
can do with Flash.

The Flash Professional online documentation includes the instructions on how to use the features and includes
links to related videos and tutorials to achieve specific tasks.

The Flash community forum is helpful for researching questions and learning techniques from other Flash
developers; always search before submitting new posts, because there is a wealth of posted information that
you can use to find solutions to common questions.

Very helpful

Excellent! Thank you!

good tutorial

great tutorial!

Great introduction! Very easy to follow.

Good Tutorial ;)

Great starting point, easy to follow, thank you.

I haven't touched flash since the Macromedia days; you've made some serious changes since the prehistoric times - lovin' it. 

  

Very helpful - much appreciated!
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Pink Lava Lamp

October 31, 2010

TheOriginalChaosChaser

November 5, 2010

Altwing11572

December 2, 2010

On the whole, this is the clearest tutorial I’ve tried, as a raw beginner.  

I did, however, have a few difficulties along the way. It could just be me, but… 

  

Setting the background color: “…change the color of the Stage by clicking the swatch and selecting a different color.” As there is a color swatch box to the top left of the properties panel, I got confused.

It wasn’t clear that the little box next to the word “Stage” was the color swatch one had to click. I had similar difficulties with “Click the stroke color swatch in the Property inspector”. I know you used all

the correct terms/labels, but they are terms/labels a beginner doesn’t know, and I hit information/confusion overload on that one. 

  

I clicked the Oval Tool (O) as instructed, but when I got to the part of turning it into a symbol, the selection tool only made it go spotty. No “square bounding box”. I did it all again, exactly the same, with

an Oval Primitive Tool (O), and the box appeared. What happened there? 

  

I followed the directions to changing the “shape of the motion guide path”, and it didn’t work. I did the definition of insanity by doing the same thing over and over, and suddenly it worked. I don’t

know why. So I haven’t really learned how to do this bit.  

  

Everything else went quite well, until copying and pasting the strange code in the Actions panel for the replay function. I got it, but a reminder of where the Actions panel is located would have been

most helpful.  

  

Working with children, I learned how to speak “in crayon”. I need Flash instructions to be written 'in crayon' too!

A very worthwhile tutorial for an absolute beginner.  

   

I would agree with all comments made by konfoozled (above). While I managed to get the tutorial successfully completed, the description in the tutorial text was not entirely accurate or was a little

confusing.

Using CS5 trial I downloaded today. I completed it but agree with the problems noted previously. Also the animation path I was intially shown was a straight line as the tut showed but when I moved the

ball to frame 10 on the path the path changed to curves. No keyframe was created (step left out of tut?) but I added it manually. The replay button did not show in my browser window when I opened

the HTML file because I had placed it outside (tut said place it anywhere I like) of the colored backgroud (stage size) moving it into the stage fixed this. I like the format of this tutorial but in order for it to

be useful to to beginners it MUST be accurate (I used to be an AutoCAD trainer). Thanks

Works perfect, and i am an absolute beginner. My experience was that the text was 100% accurate (when i thought it was not it turned out to be my false handling), with only one exception at the end.

What i did not understand was the following:  

I quote: "Enter the text Replay into the label field in the Component Parameters area in the Properties panel". There is no such editable label field in the properties panel!!! The properties panel related to

the component button only contains position and size, color effect and display.   

   

But my workaround: I simply added the line ' replay_btn.label="repeat";  '   to the action script, and then the button label displays "repeat". This because the properties panel is in fact just a more

comfortable UI for parameters you can always set within a script.   

   

For all the button properties you can easily set in a script instead of searching for editing possibilities within the properties panel see

http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/mx/controls/Button.html

Very helpful.  Be prepared to follow the instrutions carefully.

I am working with CS5 Design Premium, Student Version.  I have followed the tutorial to step 8 (Using a stop action to stop the Timeline from looping).  However, the stop(); command is ignored and the

movie keeps looping. 

  

In fact, the reason I looked up this tutorial is because all my timeline code  has been ignored by the compiler. Since CS5 is new, I thought things might have changed, but that doesn't appear to be the

case.  Does this mean my disc or install was corrupted?  Or was there a bad update?  I installed all updates.
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mkkp7
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kglad (Moderator)
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kieeikkie

December 13, 2010

Stefan Gruenwedel (Administrator)

December 22, 2010

Chong Groover

January 7, 2011

@OriginalChaosChaser...I am also working with CS5, and have had no problems following this tutorial.  Well, I had problems... it took me two hours to get my little ball moving on the screen... but most of

it was just me being new to Flash.    

   

However, I took notes of all the places I got stuck, where it appears that this CS4 tutorial was not updated for CS5, so perhaps something in the following can help you:  

   

Before starting Flash, I had to deviate slightly from the tutorial script as I was given the option to take place in Adobe CS Live Online Services.  I did log onto that, but I’m going to ignore it for now as the

tutorial seems easy enough.   

   

All right, it was easy enough to follow the steps of creating and saving the file.  The first challenging bit came when I had to find the ‘oval’ tool, as it is not obviously displayed anywhere.  Rather it is part

of the rectangular tool, and you have to first double click on the rectangular tool to get the oval tool.   At this point I suspect that this tutorial is for CS4 as some of the instructions are out of date; for

example it is saying that the Fill Color Picker is below the Stroke Color Picker when it is actually to the right of it.  Also, the ‘No color’ option appears to have already been pre-selected.    

   

I have no idea what ‘shift-dragging’ means.  My assumption is that it means holding down the Shift key while moving the mouse around.  This appears to work as I have created a grey circle.    

   

So far so good.  I have turned my circle into a symbol and successfully tweened it back and forth, and have even added a change in direction.  

   

All right, I have now encountered my first problem.  I have selected the motion guide path in an attempt to change the shape of it, but all I am doing is moving the path up and down and left and right,

but not actually making it bend or curve.  Ah… success.  I ending up having to actually deselect the motion guide path so that it no longer glowed bright green from end to end.    

   

Okay, now I’ve tested my movie.  Against, CS5 is giving me more options of how I want to test this movie than the tutorial mentions.  Not having any idea, I leave the radio button on the default

choice.  Success!  My grey ball goes up and down on a red background.  

   

The part about publishing was no problem, beyond the fact that IE didn’t want me running Flash.  But that’s a problem with IE, not with Flash.  

   

Now the last part about adding a ‘replay’ button is very difficult.  Or at least the instructions are not very well written.  I'm stuck on part 3, as I can't find the "<instance name>" field.   I’m going to have to

look at the link for making buttons.   

   

* * *  

   

All right, my research has paid off.  I needed to go to the Windows tab, then to Properties in the drop down menu and Properties again.    

   

I attempted to type the code snippet as written, but I appear to have made some sort of typo that I can’t find.  For the moment, I am just cutting and pasting (as the tutorial suggests, at any rate) and am

meeting with success.  I suppose I will have to research Action Script a bit more and figure out if I accidentally used a colon instead of a semicolon or some such thing.  At any rate, all done!  Success!  

   

(By the way, it took about 2 hours of behind the scenes effort just to move a little grey ball across a red screen!  Sheesh!   I’ll have to remember that this will be time-intensive until I learn what I’m doing

a bit more.)  

   

* * * * *  

   

I do recall that at first all my timeline code was also ignored by the computer, but that was because I did not type it in perfectly and exactly.  You are probably making a typo that you haven't spotted just

yet.  

   

   

Everything worked except the replay button... I did exactly what the tutorial says but when I test it, not only does the stop function not work anymore, but the button is flickering and it says this in

"Ouput" :  

   

**Warning** The linkage identifier 'fl.controls.Button' was already assigned to the symbol 'Component Assets/replay_btn', and cannot be assigned to the symbol 'Button', since linkage identifiers must be

unique.  

   

What's the problem?

only the button component should be using that class.  if you want to customize the button component, you can skin it.

Clear and concise.

Today we updated this article to address many of the comments posted previously by readers. As Pink Lava Lamp wrote on 10/31/10, "Be prepared to follow the instructions carefully." We also added

many links to the Flash glossary to help readers understand basic Flash concepts better.
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cary abramoff

March 2, 2011

cary abramoff
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Aravindasweety

March 10, 2011

deep childs

March 10, 2011

Stefan Gruenwedel (Administrator)

March 15, 2011

Dbrainiac64

Thank you so much for creating such a detail-oriented tutorial for a beginner like me!!

Hi, 

  

I'm a professional programmer for almost two decades fluent in C#, jquery, JS, HTML, Silverlight and many other languages. 

  

I have also written a tremendous amount of tutorials and further have designed many user interfaces. 

  

This tutorial had me cursing like a sailor for two reasons. 

  

One... the timeline and the replay button. 

  

Could not get it to work and I am moving on to better tutorials. 

  

I got the animation working in 5 minutes as I am familiar with vector graphics apps. 

  

However, the timeline and the keyframes are ridiculous. You have microscopic dots, and somehow I am supposed to bust out the 20X magnifying goggles to work with them. 

  

Do they pertain to ... what... I end up with a bunch of tiny dots and the harder I try to figure it out the more my eyes hurt. Most developers sit in front of a screen 100 hours a week.... do you? Maybe if you

did you would not wanna deal with tiny dots, especially as a newbie..... and I have 20/20 vision... 

  

Finally compiler errors galore when adding replay button snippet. Sure there's a vague warning about not pickin' this or that by accident.... But whoever wrote this tutorial is abysmal at technical writing. 

  

Break up those paragraphs. 

  

Use bulletin' points. 

  

Hell, offer a downloadable zip with the WORKING source code so newbies can compare and contrast. 

  

I am only here because I inherited a Flash project I need to modify. 

  

This is sooooo frustrating.... The comments here are far too kind. 

  

Why does my replay button bounce along with my moving graphic. 

  

Do I need to post back and forth to figure out how to add something so simple as an event handler? 

  

Just add a ZIP sample. That's all. 

  

And break up those run on convolluted sentences. 

  

I'd give this 0 stars and mark it a MAJOR TURNOFF to newbies. 

  

Sorry but that's the truth.

ps- i did get the event handler working but again, way too convoluted. even after getting it to work it is still clear as mud...... if a picture is worth a thousand words a companion sample is worth a

guhzillion....

It was very helpful.Even the guys who dont know basics can easily work on it now.......

Hello to all I am a newbie just starting never knew anything about adobe flash. I must admit I am really enjoying the vector side of things. Im not a programmer i dont read nor write in code but slowly

but surely im gettin better with it all hey ya gotta see things ive done 2 thumbs up adobe. Is there anyting better?

We have added a sample file to the top of the article page to provide readers with something to explore and play with from the start. The sample files show a working version of the completed project.

Of course, you can also just follow along with the instructions provided to create your sample project from scratch. 

  

</sg>
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Keith Howell
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dmansha

April 9, 2011

Tausif Javed

April 12, 2011

pereiradurango

April 21, 2011

Raj Goud

April 25, 2011

zircon747

April 27, 2011

Fleurence

May 19, 2011

harneet chugh

May 22, 2011

Mindie Chu

June 12, 2011

Nile Cummings

June 25, 2011

The instructions were well written.  I am a Flash novice, but was able to follow each step and create the animated flash file.   This was a great tutorial!! 

I don't understand your direction above "only the button component should be using that class.  if you want to customize the button component, you can skin it."  Too much jargon there.  I don't know

what "class" is or "skin it" means.  But I have repeatedly gone step by step by step to reproduce this and compared my file with the sample file but the "Replay" button continues to flicker and the

animation stays in a loop.  Feeling very stupid as I'm usually pretty intuitive with Adobe programs.  This is literally my first time looking at trying to learn Flash tho. The only error I get is on the Output

tab where it says "WARNING: The component 'Button' requires ActionScript 2.0."  But the same warning is on your sample file and it runs fine.  If I adjust my publisher settings to 2.0 then the whole thing

goes kablooie because everything else requires 3.0.  

   

I'm about to give up.   

I am a total newbie to flash and I got it working the very first time. Very well written and quite thorough. 

  

great tutorial. but i know already.   

what's new in flash cs5.

I’m a beginner in Flash CS4, usually when one touches a shape, a square, a circle,   

this is selected with the arrow, (selection tool) filled with white spots. Now it does not do that command, when I touch that it doesn’t work. Maybe I’m touched or do something wrong, I don’t know how

to make it work normal again. 

When you convert a text in in “break apart” doesn’t work. 

With the previous file of Flash4, they kept changing selection, but if you add a new shape doesn’t change the selection. It does not work, what can I do? Please help me. 

Thank You

This is great. I did it for browser. Does anybody know how to create .swf for mobile phone 176x220 pixels with Flashlite 1.1

nice thanks

Merci enormément, c'est trés utile comme premier pas.

First of all - a great tutorial for beginners.. !  

  small glitch at the end... when I opened the published file SimpleFlash.html with internet explorer 8, I got the yellow bar ActiveX control warning. It did not happen with other browsers – chrome, firefox,

safari. Using windows vista. Kindly help.

I had no difficulty stepping through this tutorial.  Reading the differing comments, I imagine that brain functions are like food taste - subjective.
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Fred Weaver
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July 20, 2011

Murtada Rabah

July 24, 2011

Simon Nicolaou

July 27, 2011

Ed Taylor

August 16, 2011

I'm stuck.  I've tried ten times to get the "stop();" script into the right place as demonstrated in the first lesson "Creating your First Flash Project."  I moved the playhead to frame 24 and inserted the

keyframe there, with the actions layer selected.  Then I inserted the keyframe.  But then when I open the Actions Panel like the lesson instructs and paste the ActionScript Code into the box, the little "a"

icon pops up in the wrong place.  It is way on the left side of the timeline, in Frame 1 rather than in Frame 24  What am I doing wrong?    

      

Also, my version does not match with the lesson graphics/text in the publish settings window.  In my version, the Publishing Settings Dialogue Box has no tabs at all and it looks completely different

from the one displayed in the lesson. I am not able to configure the settings as the lesson instructs.  It makes following the lesson kind of challenging. I am using the 30-Day trial version of Flash Pro

CS5.5 (v 11.5.0.325)    

      

Any assistance on these issues is most appreciated.    

      

Thank you very much.

This tutorial is very helpful.  When I first decided to get this software, I was a little intimidated, but the tutorial makes the process of producing flash animations much less daunting.  I look forward to

what I will create thanks to this tutorial.

Thank you very much

Worked fine until I needed to change the button text per:  "To update the text label of the button that is displayed on the Stage, enter the text Replay into the label field in the Component Parameters

area in the Properties panel." 

I'm using CS5.5 Mac and I cannot find any "Component Parameters" . Another screen shot please! 

Oh, and the section on publishing...there are no Formats/Flash/HTML tabs on my dialog box.

If you have any  problems with the replay button you need to rename ''replay_btn''. 

Copy and paste this code:import flash.events.MouseEvent; 

    

function onClick(event:MouseEvent):void 

{ 

    gotoAndPlay(1); 

} 

button_btn.addEventListener(MouseEvent.CLICK, onClick);  

  

please rate it if it works well I'm pretty good for a begınner!

I found this tutorial easy to follow and extremely helpful as a complete Flash novice.  Thanks so much!  I am now even more excited about learning how to use Flash.

Hi there  

Great tut, very helpful for beginner like me , but in publishing sittings , I think that it’s made for CS4 , Coz in CS5.5 it’s much different which make me getting wacko for a while.  

   

Looking forward for more wonderful tutorials such as this one.  

Very nice, 

  

Well explained and gives me hope that I may finally add a bit of animation to my skill-set. 

  

Thankyou
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Dustin Milligan
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tawfik khatab
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MATTWVC

September 3, 2011

Girma Orssengo

September 3, 2011

Luke Hill-Cottingham

September 6, 2011

David Jones

September 15, 2011

Page: 1 2

I followed instructions and had no problems.  I learned to use a Macromedia Flash program in '04-'05. I can see that you have simplified many of the functions.  

  

I agree that following the instructions implicitly is very important. When learning Flash the first time I found that when a mistake is made it sometimes creates programming blocks to your intended goal

therefore requiring "undoing" what you have done in order for the program to work properly or it takes you down a pathway of thought that must be abandoned in order to return to the original

intent.   

  

I had no problems with these instructions.  Great job. 

I had trouble changing the line I right clicked it by accident and it messed me all up but otherwise very easy.

I have read and watched a number of tutorials on Flash before going over this article. This one really put me in the right perspective. I suggest any new starters read this one first.

www.qualityresearch.org.uk.

I did flawless as this is my intro into FLASH PRO! I have used a few SDK kits for mobile app building, but this was so much more fun and easy! 

  

I went and got like 4 books from the library, but when i opened up Flash this was the first helper of several, so now i am off to do the next, I couldn't of asked for a easier start point! 

  

I am in it to learn to make my own apps and this tutorial has already shown me fundamentals and has already taught me several things that every user should know and use! I am sure when i go Pro, I

will be using the things I learned here today! 

  

I am sure after i go though all the help with help files that Adobe offers, then i will be able to do my own thing and with a little help from the books I will definitely be able to make my own apps and

put them on the market!

A brilliant tutorial.  

   

Thank you.  

   

Learned the basic principles of Flash animation in one Saturday after noon  

   

Thank you again.  

Great Tutorial! 

  

RE: "Replay Button" 

  

Although one minor thing you missed out on. 

Not sure if this is actually the case, it'd be nice if someone verified this but - 

Naming the button and the coding, like you said is a important thing to do, you need to emphasise that it's Caps sensitive, i found that when i named the replay button "Replay_btn" then typed in the

coding "reply_btn" it didn't work and I hit an error.  

  

Just a little thing which wasn't too hard to pick out, but if you're a beginner, it's the little things which really catch you out.  

  

Apart from that, Flawless! 

  

Thank you.

Brilliant! I'd never used flash before (or any creative software other than Photoshop) and this was dead simple to follow even though it was written for CS 4 and I'm using CS 5.5. Now show me how to

shoot an arrow across the stage into a target and make the arrow wobble when it hits the target..please

Please sign in to post a comment.
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